Why does Reverb not support my browser?

In December 2015, the PCI Security Council, which oversees security guidelines for payment processors, introduced new requirements for handling online payments. These new guidelines go into effect on June 30th, 2018, and mandate the usage of a security protocol called Transport Layer Security (TLS), version 1.2.

Both Reverb.com and modern web browsers have been compliant with this standard for years. For the majority of users, no changes are required. However, older web browsers and older operating systems that do not support TLS 1.2 may no longer fully be able to use Reverb once these changes go into effect. In addition, older mobile clients may also be impacted if you haven’t updated to the latest Reverb mobile app.

To upgrade your browser to a newer, secure version and continue using Reverb, or for links to browsers we support, please see our guide. If you have any issues with buying on Reverb, please reach out to our support team who will be glad to assist further.

Was this article helpful?
0 out of 0 found this helpful
Still have questions? Chat Us or Submit Help Request